Python图片处理模块Pillow

发布时间:2017-09-13 12:43:27
Python图片处理模块Pillow 安装 警告 * Pillow 不能和PIL 同时存在于一个环境中,在安装Pillow之前需要先卸载PIL * Pillow 1.0 版本后已经不支持import Image,请使用from PIL import Image来代替 * Pillow 2.1.0版本以后已经不支持import _imaging,请使用from PIL.Image import core as _imaging来代替 提示 * Pillow 2.0.0 版本之前只支持Python 2.4、2.5、2.6、2.7 * Pillow 2.0.0 版本之前只支持Python 2.6、2.7、3.2、3.3、3.4、3.5 基本安装

提示:使用PyPI安装可以工作在Windows、OS X和Linux中,使用源码包需要组建依赖环境

使用pip安装Pillow:

$ pip install Pillow

或者使用easy_install

$ easy_install Pillow Windows安装

官方提供了wheel,egg和二进制程序32位和64位平台的Pillow二进制文件,这些二进制文件拥有所有的第三方库

$ pip install Pillow

或者:

$ easy_install Pillow OS X 安装

官方提供了OS X 系统中所有所支持的Python版本的wheel格式的二进制程序,并且已经支持所有可选的库

$ pip install Pillow Linux 安装

官方在Linux中不提供任何额二进制包,不过这里还是可以使用pip或者easy_install来安装毕竟我们有Python,当然我们也可以通过源码包来安装

这里不对源码包安装进行翻译,如果想要使用那么请点击此链接进行跳转

平台支持 操作系统 是否支持 Python版本 Pillow 最终测试版本 操作系统类型
Mac OS X 10.11 El Capitan Yes 2.7,3.3,3.4,3.5 3.0.0 X86-64
Mac OS X 10.10 Yosemite Yes 2.7,3.3,3.4 3.0.0 X86-64
Mac OS X 10.9 Mavericks Yes 2.7,3.2,3.3,3.4 3.0.0 x86-64
Mac OS X 10.8 Mountain Lion Yes 2.6,2.7,3.2,3.3 x86-64
Redhat Linux 6 Yes 2.6 x86
CentOS 6.3 Yes 2.7,3.3 x86
Fedora 20 Yes 2.7,3.3 2.3.0 x86-64
Ubuntu Linux 10.04 LTS Yes 2.6 2.3.0 x86,x86-64
Ubuntu Linux 12.04 LTS Yes 2.6,2.7,3.2,3.3,3.4,3.5PyPy2.4,PyPy3,v2.32.7,3.2 3.0.0,2.6.1 x86,x86-64,ppc
Ubuntu Linux 14.04 LTS Yes 2.7,3.4 3.0.0 x86-64
Debian 8.2 Jessie Yes 2.7,3.4 3.0.0 x86-64
Raspian Wheezy Yes 2.7,3.2 2.3.0 arm
Gentoo Linux Yes 2.7,3.2,2.1.0 x86-64
FreeBSD 10 Yes 2.7,3.4,2.4.0 x86-64
Windows 7 Pro Yes 2.7,3.2,3.3,2.2.1 x86-64
Windows Server 2008 R2 Enterprise Yes 3.3 x86-64
Windows Server 2012 R2 Yes 2.7,3.3,3.4 3.0.0 x86-64
Windows 8 Pro Yes 2.6,2.7,3.2,3.3,3.4a3,2.2.0 x86,x86-64
Windows 8.1 Pro Yes 2.6,2.7,3.2,3.3,3.4 2.4.0 x86,x86-64
手册 教程

企业建站2800元起,携手武汉肥猫科技,做一个有见地的颜值派!更多优惠请戳:荆州SEO http://jingzhou.raoyu.net